Re: [PHP-DEV] [RFC]

This is only part of a thread. view whole thread
  108553
February 13, 2020 22:26 d.h.j.takken@freedom.nl (Dik Takken)
On 13-02-2020 19:19, Mike Schinkel wrote:
> But since I seem to be in the minority of caring about the name, let me propose the following which was influenced by Larry Garfield's most recent post. Since it seems that people want the convenience of a short notation to get a closure, how about this: > > function foo{} > > foo::function — Returns name of function > foo::fn — Returns closure for function > > Since using `fn` creates anonymous function closures it kinda makes sense that `::fn` would return a closure.
That is somewhat confusing in my opinion, the two class constants are too similar. I would rather prefer: foo::function — Returns name of function foo::closure — Returns closure for function Regards, Dik Takken
  108557
February 14, 2020 00:31 mike@newclarity.net (Mike Schinkel)
> On Feb 13, 2020, at 5:26 PM, Dik Takken takken@freedom.nl> wrote: > > On 13-02-2020 19:19, Mike Schinkel wrote: >> function foo{} >> >> foo::function — Returns name of function >> foo::fn — Returns closure for function >> >> Since using `fn` creates anonymous function closures it kinda makes sense that `::fn` would return a closure. > > That is somewhat confusing in my opinion, the two class constants are > too similar. I would rather prefer: > > foo::function — Returns name of function > foo::closure — Returns closure for function > > Regards, > Dik Takken
I actually prefer foo::closure over foo::fn though either would be fine with me, especially if it means getting the feature vs. not getting the feature. The reason I proposed ::fn was because I trying to suggest something that I though Larry Garfield would appreciate given his recent comment[1] in response to you where he said: "Analysis: I stand by my earlier statement that ::function is just too damned long for this funtionality. Not when already reserved shorter options exist. ::fn" -Mike [1] https://externals.io/message/108459#108542