On Tue, Feb 11, 2020 at 2:11 PM MichaÅ Brzuchalski
> wt., 11 lut 2020 o 13:59 Guilliam Xavier email@example.com> napisaÅ(a):
>> On Tue, Feb 11, 2020 at 1:12 PM Nicolas Grekas
>> firstname.lastname@example.org> wrote:
>> > >
>> > > Just so someone has mentioned it... is "Stringable" really the best name
>> > > for this interface? Reddit really didn't like it ;) Some possible
>> > > alternatives: ToString, HasToString, CastsToString.
>> > >
>> > Naming things...
>> > I'm not sure reddit is the way to lobby php-internals...
>> > I proposed Stringable because it is the most consistent to me:
>> > Traversable, Serializable, Countable, Throwable, JsonSerializable
>> > all are related to some special engine behavior, which this ones also is.
>> But one could argue that "string" is not a verb like "traverse",
>> "serialize", "count", "throw" etc.
>> Potential alternatives would be Stringifyable (or Stringifiable?),
>> StringCastable, StringConvertible...
>> (Even though I personally have no problem with "Stringable")
> Maybe StringObject? We do already have ArrayObject.
But ArrayObject is not a interface (ArrayAccess is).