> I feel like changing the default value of $enableExceptions to TRUE
> makes more sense since that is what you would expect from the original
> function call as it stands and is the least breakage of anything
> already existing (since making it a required variable would throw
> ArgumentCountError for any existing code).
> WRT the PR you mentioned (since it's my own), do you think it would be
> better to change the current toggleExtendedResultCodes to
> enableExtendedResultCodes and have a similar function prototype to
> enableExceptions? I didn't consider that when I wrote my changes (to
> be honest I don't use the sqlite3 class directly so I didn't know
> about it, I only used the pdo_sqlite layer above it).
I thought about proposing that, but I wanted to run this issue by
internals first to hear others thoughts on the matter. I definitely
think consistency is something we should embrace more and thinking
about it for a day then I do think we should keep the naming similar,
but avoid a design like SQLite3::enableExceptions().
Kalle Sommer Nielsen