[RFC] Provide argon2 support for password_hash() from ext/sodium

  105115
April 5, 2019 17:52 pollita@php.net (Sara Golemon)
I was originally planning to just do this since I thought it'd be
non-controversial, but while implementing I discovered some gotchas, so I'm
putting it to the group for discussion.  Please give attention to the
"Backward Incompatible Changes" section.

https://wiki.php.net/rfc/sodium.argon.hash

-Sara
  105116
April 5, 2019 18:25 george.banyard@gmail.com ("G. P. B.")
On Fri, 5 Apr 2019 at 19:52, Sara Golemon <pollita@php.net> wrote:

> I was originally planning to just do this since I thought it'd be > non-controversial, but while implementing I discovered some gotchas, so I'm > putting it to the group for discussion. Please give attention to the > "Backward Incompatible Changes" section. > > https://wiki.php.net/rfc/sodium.argon.hash > > -Sara >
I'm all for it however isn't a 2/3 majority required for all RFCs now? Best regards George P. Banyard
  105118
April 5, 2019 18:36 pollita@php.net (Sara Golemon)
On Fri, Apr 5, 2019 at 1:25 PM G. P. B. banyard@gmail.com> wrote:

> I'm all for it however isn't a 2/3 majority required for all RFCs now? > > Oh, indeed. Hadn't noticed that get voted on. Neat! Have updated RFC to reflect. Thanks!
  105117
April 5, 2019 18:29 dzuelke@salesforce.com (David Zuelke)
You're listing libsodium versions 0.15 and 0.13 there, but it should
be 1.0.15 and 1.0.13.

Maybe for everyone's reference: Ubuntu 16.04 LTS comes with no
libargon2, and with libsodium 1.0.8; 18.04 LTS comes with libargon2
and with libsodium 1.0.16.

Debian Stretch has 1.0.11, and 1.0.17 in backports.

On Fri, Apr 5, 2019 at 7:52 PM Sara Golemon <pollita@php.net> wrote:
> > I was originally planning to just do this since I thought it'd be > non-controversial, but while implementing I discovered some gotchas, so I'm > putting it to the group for discussion. Please give attention to the > "Backward Incompatible Changes" section. > > https://wiki.php.net/rfc/sodium.argon.hash > > -Sara