Re: [PHP-DB] MySQLnd support for ed25519

  49196
September 8, 2021 13:20 dimi_php@protonmail.com (dimi_php)
Hi Ruprecht,

yes, if a provider not changed the default authentication (mysql_nativ_password) there is
nothing customers have to do, because the default authentication on mysql 5.7 and 10.5 is
the same (SHA-1 based).
Mysql changed this starting from version 8, were the default authentication now is the plugin caching_sha2_password.
Mariadb not changed the default, but recommends to use a safer authentication method like the ed25519-plugin.

I would like to use it, but then i have the problem that PHP (the Mysql nativ driver) cames with an
error like "The server requested authentication method unknown to the client".

So i would be glad if this authentication method would be implemented.

Regards,
Dimi
  49197
September 8, 2021 14:01 rhelms@rheynmail.de (Ruprecht Helms)
Hi Dimi,

I think mysql 8 is the new version of mysql. I don't know if there a 
exists a stable release or only a beta.
My thoughts are that the last php-version maybe can handle the mentioned 
authentication method or you have
to try to compile the handling for the mysql-plugin in the php-mysqldriver.

Maybe the question about enhancing the php is relation on the 
Linuxdistribution.  Here I mean an additional rpm if you use Redhat, 
Fedora, Centos, Suse...
or .deb if you use Debian, Ubuntu or such of these.

To mix a tarball with one of these packages I think it is to difficult 
in this case.

Regards,
Ruprecht

Am 08.09.21 um 15:20 schrieb dimi_php:
> Hi Ruprecht, > > yes, if a provider not changed the default authentication (mysql_nativ_password) there is > nothing customers have to do, because the default authentication on mysql 5.7 and 10.5 is > the same (SHA-1 based). > Mysql changed this starting from version 8, were the default authentication now is the plugin caching_sha2_password. > Mariadb not changed the default, but recommends to use a safer authentication method like the ed25519-plugin. > > I would like to use it, but then i have the problem that PHP (the Mysql nativ driver) cames with an > error like "The server requested authentication method unknown to the client". > > So i would be glad if this authentication method would be implemented. > > Regards, > Dimi
  49198
September 8, 2021 14:15 php-db@lists.php.net ("Jonathan Aquilina via php-db")
Mysql 8 is already the stable version and has been for a while. I for development use it on windows and its v8



-----Original Message-----
From: Ruprecht Helms <rhelms@rheynmail.de> 
Sent: 08 September 2021 16:02
To: php-db@lists.php.net
Subject: Re: [PHP-DB] MySQLnd support for ed25519

Hi Dimi,

I think mysql 8 is the new version of mysql. I don't know if there a exists a stable release or only a beta.
My thoughts are that the last php-version maybe can handle the mentioned authentication method or you have to try to compile the handling for the mysql-plugin in the php-mysqldriver.

Maybe the question about enhancing the php is relation on the Linuxdistribution.  Here I mean an additional rpm if you use Redhat, Fedora, Centos, Suse...
or .deb if you use Debian, Ubuntu or such of these.

To mix a tarball with one of these packages I think it is to difficult in this case.

Regards,
Ruprecht

Am 08.09.21 um 15:20 schrieb dimi_php:
> Hi Ruprecht, > > yes, if a provider not changed the default authentication > (mysql_nativ_password) there is nothing customers have to do, because > the default authentication on mysql 5.7 and 10.5 is the same (SHA-1 based). > Mysql changed this starting from version 8, were the default authentication now is the plugin caching_sha2_password. > Mariadb not changed the default, but recommends to use a safer authentication method like the ed25519-plugin. > > I would like to use it, but then i have the problem that PHP (the > Mysql nativ driver) cames with an error like "The server requested authentication method unknown to the client". > > So i would be glad if this authentication method would be implemented. > > Regards, > Dimi
-- PHP Database Mailing List (https://link.edgepilot.com/s/bc6bf762/v5jGKG7Xd0e-fT3zNkB0xg?u=http://www.php.net/) To unsubscribe, visit: https://link.edgepilot.com/s/cb035ec6/Rl3bBHstt0_Aj5u5ZnK0vg?u=http://www.php.net/unsub.php